Issue: Disruption to Services Wednesday 7th August 2024 16:14:12


Dear Customers, we regret to inform you that there has been a disruption to our services in the Moruga areas which may affect your Internet and Cable TV services. The exact cause is unknown at this time and our team has been mobilized to investigate the matter and restore services as soon as possible. Updates and an estimated time for the return of services will be shared as soon as the information becomes available. We sincerely apologize for any inconvenience caused.

Please note area has been restored.

Update: Affected areas: Cunjal, Jaipaulsingh Road, Oropouche North, Rochard Douglas road, Poui Trace and Moruga Team is on site. ETR: 4 hours Issue: main lines pulled down